US and CA Regions - Dashboards Unavilable

Incident Report for Survey Dynamix

Resolved

A hot-fix has been deployed to correct this issue.

All US and CA regions have been updated and validated as issue resolved.

If you continue to have any issues with dashboards, please open a support ticket via the portal.
Posted Jul 16, 2025 - 16:04 UTC

Identified

Issue: Impact to view dashboards on US and CA Mindful Feedback regions. Dashboards not available to view. Calls and surveys are processing as expected across the regions.

ETA to resolution: Estimated currently at 7/16, however subject to change*

The issue has been identified and a fix is being worked on. Multiple clients have reported dashboard outages and this issue has been escalated.
Posted Jul 15, 2025 - 16:21 UTC
This incident affected: Reporting.