Platform - Log-in unavailable and slow processing of dashboards and reporting

Incident Report for Survey Dynamix

Resolved

This incident has been resolved.

Changes within the update maintenance performed last night (12/3/25 - 12/4/25) caused disruption with the Database resulting in the system issues seen today.

We will continue to monitor for any further issues and ensure the platform is fully resolved. A formal RCA will be available at a later date and can be requested by opening a support case.
Posted Dec 04, 2025 - 20:54 UTC

Update

Changes have been made to resolve the platform processing and log-in issues. We are currently seeing the platform perform as expected.

Changes within the update maintenance performed last night (12/3/25 - 12/4/25) caused disruption with the Database resulting in the system issues seen today.

We will continue to monitor for any further issues and ensure the platform is fully resolved. A formal RCA will be available at a later date and can be requested by opening a support case.
Posted Dec 04, 2025 - 19:57 UTC

Update

We continue to actively troubleshoot and monitor the changes made for platform improvement

**Login issues have been corrected, HOWEVER we are seeing intermittent login outages as we work through changes related to improving the processing.

We are monitoring a deprecation in processing speed of the US2 and US3 regions - You may continue to see slow loading of dashboards and reporting
Posted Dec 04, 2025 - 18:42 UTC

Update

We continue to monitor the changes made for platform improvement.

**Login issues have been corrected, HOWEVER we are seeing intermittent login outages as we work through changes related to improving the processing.

We are monitoring a deprecation in processing speed of the US2 and US3 regions - You may continue to see slow loading of dashboards and reporting
Posted Dec 04, 2025 - 17:35 UTC

Monitoring

We continue to monitor the changes made for platform improvement.

Login issues have been corrected and now available.

We are monitoring a deprecation in processing speed of the US2 and US3 regions - You may continue to see slow loading of dashboards and reporting
Posted Dec 04, 2025 - 17:03 UTC

Identified

The issue has been identified and a fix is being implemented.
Services may slowly become available at this time.
Posted Dec 04, 2025 - 16:00 UTC

Update

Update:
Currently, US2 and US3 are the regions impacted.
Possible issues with logging into the product and/or slow and intermittent loading of dashboard screens.
Posted Dec 04, 2025 - 14:47 UTC

Investigating

We are currently investigating an issue causing US2 instance to deny log-in and/or process slowly.
Posted Dec 04, 2025 - 14:26 UTC
This incident affected: Platform.